
Fluorescence microscopy & Single 

Molecule Localization Microscopy  
Overview 

In this module, we will study the application of fluorescence microscopy in biophysical research. We 

will see what advantages fluorescence microscopy has, the limit of resolution of optical microscopy and 

how single molecule localization microscopy can overcome this limit. For these purposes, you will image 

some biological specimens, understand how a fluorescence microscope works, build your own microscope 

and image the specimen with both regular and super-resolution fluorescence microscopy. 

Introduction to fluorescence microscopy and single molecule localization microscopy 
  

Absorption of light and subsequent re-emission (which happens nearly simultaneously, typically a few 
nanoseconds) by organic and or inorganic molecule is called fluorescence. Only a few molecules actually 
fluoresce, but those that do and can be placed at a position of interest, are extremely valuable. Watching 
where a labeled biomolecule is, or moves around, can be illuminating. When looking at the object through 
a microscope, fluorescence microscopy has become an essential technique in biological sciences due to 
its availability of high contrast and specificity.  

The basic function of a fluorescence microscope is to irradiate the specimen with a specific band of 
wavelengths, and then to separate the much weaker emitted fluorescence from the excitation light (Fig. 
1). In a properly configured microscope, only the emission light should reach the detector so that the 
resulting fluorescent structures of the specimen are visualized with high contrast against a dark (almost 
0) background. The limits of detection are generally governed by the darkness of the background, and the 
brightness of the fluorescence. Under ideal conditions, it is possible to detect a single fluorescent molecule, 
provided that the background and detector noise are sufficiently low. (One real consideration, is that the 
excitation light, necessary to induce the fluorescence, is typically 105 -106 times brighter than the emission, 
so getting rid of this, is a very important.) 

Optical microscopy, i.e. where the wavelength of excitation or emission is roughly 400-750 nm, 

including fluorescence microscopy, has limitation of its resolution defined as /2NA, called the 

diffraction limit of light where  is the wavelength of the light and NA is the numerical aperture --which 

is the range of angles over which the lens can collect the light-- of the detection objective of the 
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Figure 1. Absorption and fluorescent emission of a molecule. Excitation (blue) light is absorbed by the 
molecule and emitted (green) from the molecule. 



microscope. While the fluorescent object is only in nanometer in size or-so, it’s emission (i.e., its 

fluorescence light) is ~ 250 nm. Why? Even though the light was emitted from a point source, at the 

image plane wavelets from different points of the wave front undergo interference, forming blurry Airy 

distribution of light which is ~/2.(See the interactive tutorial:  

http://micro.magnet.fsu.edu/primer/java/imageformation/airydiskformation/index.html and “What is 

resolution”, which can be found on the web page  of Physics 498EBP) 

This limitation defines the minimal dimension of the structure one can distinguish in the specimen 
by using optical microscopy, which is about 250 nm for visible light. 

 
Figure 2. Principle of single molecule localization (FIONA). The figure shows a point spread function (PSF). The width of the PSF is 
blurred out (~250 nm) but one can estimate the center of the PSF much more accurately than the width. 

How can we go from something whose emission is blurred out (to ~ 250 nm), to much smaller. If we 
know that there is a single molecule present, we can figure out where the center is with much better 
accuracy than the blurred image of the molecule.  

FIONA (Fluorescence Imaging with One Nanometer Accuracy) is a powerful technique that can be 
used for making ~ nanometer accuracy localization of molecules. The premise behind FIONA is that one 
can measure the center of a point-spread function (PSF) much more accurately than the diffraction limit, 
provided enough photons can be collected. For FIONA, fluorescence from single dye molecules are 
recorded by a camera. The recorded images show bright spots which can be modeled as Gaussian 
functions (Figure 2). The accuracy of a measurement of the position (center) of the molecule is given by: 
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where N is the number of photons collected, s is the width of the distribution in either the x or y 
direction, a is the pixel size of the camera (actual pixel size of the camera divided by the magnification of 
the system), and b is the standard deviation of the background. The first term under the square root 
describes the photon noise (shot noise), the second is the effect of the finite pixel size of the camera, 
and the third is the background noise. For a pixel size of approximately 100 nm, the photon noise term 

dominates therefore the accuracy of localization is ~ s/2√N = /2NA√N. By collecting 5,000-10,000 
photon counts per second, one can localize a fluorescent molecule to within a nanometer. 

http://micro.magnet.fsu.edu/primer/java/imageformation/airydiskformation/index.html


 
Figure 3. Two molecules located further than diffraction limit (left, resolved, shown at >~250 nm) at about Rayleigh criterion 

(middle, diffraction limit) and closer (right, unresolved). 

The above depends on seeing a single molecule. What if we have two (or more molecules) within the 
diffraction limit? In Figure 3, you can see two molecules located at different distances from each other. 
When they are far enough (> diffraction limit) it is possible to distinguish two molecules. However, when 
they are closer than the diffraction limit (known as the “Rayleigh Criterion”), two molecules become 
unresolvable. How can we resolve multiple molecules located very close to each other?  

  

 
Figure 4. Principle of single molecule localization microscopy to get super-resolution. Here, the molecules within the diffraction 
limit of light are switching on stochastically, so that every molecule fluorescing can be localized at different time points. The 
collection of every localization results in the super-resolution image of the structure.  

 
In Figure 4, multiple fluorescent molecules are located within the diffraction limit. The image of the 

molecules is shown as a blurred image and it is not possible to visualize the structure beyond the limit 
(left). However, using photochemical properties of the molecules we can make the molecules blink so that 
only a few molecules far from each other can be detected at a time. By detecting the molecules randomly 
blinking at different time points, one can localize each molecule with higher localization accuracy using 
FIONA (middle). By repeating this over time until all the molecules in the specimen are detected, one can 
get the position information of every fluorescent molecule of the sample with ~10 nm localization 
accuracy. The collection of the localization of the molecules, finally show the structure of specimen with 
the resolution beyond the diffraction limit.  

 
 

 

1.  Fluorescence vs. Brightfield & Diffraction limit of light  
 

~250 

nm 

~250 

nm 



Data: images in “Fluorescence vs. Brightfield” folder. 
- Brightfield and fluorescence images of fluorescent beads with 4 different sizes 
- Brightfield and fluorescence image of a cell 

 
Instruction for analysis of images using Image J 

Use the images to answer the lab report questions. Image J is a good tool for image analysis. For the 
analysis, refer to the instruction below. 

First you need to download and install ImageJ (https://imagej.nih.gov/ij/download.html). Then 
download and install a plugin called “ThunderSTORM.” 
(https://github.com/zitmen/thunderstorm/wiki/Downloads) the instruction for installation can be found 
here (https://github.com/zitmen/thunderstorm/wiki/Installation) 
 
Instruction for measuring size of objects 

1. Start Image J and drag and drop your image file on Image J window to open the file for analysis. 
2. You can adjust brightness and contrast of the image by “Control+Shift+C” 
3. Choose the object of which size (diameter, width or thickness) you want to measure. 

4. Click   icon to select cross section of your target. 
5. Click and draw a line across the object of your interest. 

 
6. Hit “k” to measure line profile. Image J will show the following plot. 

 
7. Click “List” to see the value. 
8. For Gaussian fitting of the value copy the plot values. (Control+c) 
9. Go to “Analyze -> Tools -> Curve fitting” 
10. Paste the plot value and choose “Gaussian” for fitting curve. 
11. Click “Fit” then Image J will show you the fitting parameters. 

 
 
 
 

2. How does SMLM achieve “super-resolution?” 
 

https://imagej.nih.gov/ij/download.html
https://github.com/zitmen/thunderstorm/wiki/Downloads
https://github.com/zitmen/thunderstorm/wiki/Installation


In the second session, you will image a biological specimen, mammalian cell whose actin filament (one 
of cytoskeletons in cells) is fluorescently labeled, with super-resolution. In the previous sessions, you 
learned the diffraction limit, and how to overcome the limit in terms of localization of single molecules 
separated more than the diffraction limit. Here, in addition to the localization, you will learn how to get 
super-resolution using stochastic photo-switching of fluorophores. 
  
 Data: images in “SMLM” folder. 

- Regular resolution image of microtubule (regular.tif) 
- Sequence of SMLM image for analysis (sequence.tif, 27,529 frames) 

 
Instruction for using ThunderSTORM for analysis 
 

1. Start Image J and drag and drop your image file on Image J window to open the file for analysis. 
2. Plugins -> ThunderSTORM -> Camera setup. Enter the parameters according to the picture 

below. Photoelectrons per A/D count will vary depending on the gain value you use (Refer to the 
table). Base level [A/D counts] value will depend on the background count of your image. Move 
the cursor to dark regions of the image to measure the background.  

 

 
3. After setting up the camera, go to Plugins -> ThunderSTORM -> Run Analysis/ and enter the 

values according to the picture. 



 

4. Click “Preview”. You should be able to see red dots overlapping on the beads. If there are more 
or less red dots, go back to the camera setup and adjust the base level accordingly (increase if 
there are more red dots than the beads, otherwise decrease). 

5. After making sure that the preview looks fine, click “Ok” button next to the “preview” button. 
You will get a screen similar to the one below. 



 

6. Each column indicates following information. 
• id: (optional) column to identify each localization. 
• frame: frame number. 
• x [nm] and y [nm]: x and y coordinates of the fitted localizations. (0,0) is top left as 
conventional in ImageJ. 
• sigma [nm]: standard deviation of the gaussian fitted on the peak. 
• intensity [photon]: integrated photons number under the peak (value used to calculate the 
uncertainty in the Webb/Mortensen formulas). 
• offset [photon]: baseline of the peak (background absolute value). 



• bkgstd [photon]: standard deviation of the background (used to calculate the uncertainty in 
the Webb/Mortensen formulas). 
• uncertainty [nm]: the lateral localization accuracy. 

7. Optional: Since there are some artifact (noise) of the image, it is recommended to filter further. 
In “Filter” tab of the ThunderSTORM results window, use “offset > 1 & offset < 200”. 

 
Figure 5. Images of microtubule in the white box in Figure 8. Regular (diffraction limited, left) vs. STORM image (middle). The 
plot on the right side is the intensity profile along the white line in the figures. 

 
Lab Report Questions 

1) Fluorescence: Figure on the left side is the absorption and fluorescence emission spectra of 

Alexa647 the fluorescent dye we used for the experiment, right figure is called Jablonski 

diagram which shows possible electronic transitions by photo-excitation. 

 

a. Connect relevant or corresponding process in Jablonski diagram to ⓐ absorption, ⓑ 

fluorescence emission, and ⓒ Stokes shift. 

b. What’s the difference between ③ and ⑤? 

c. In the spectrum plot, why is emission spectrum a (almost) mirror image of absorption 

spectrum? 

2) Fluorescence vs. Brightfield microscopy 

a. In the images of beads, in which image can you see the shape of beads? Is the bead 

visible in both brightfield and fluorescence image? 

b. In the image of cell, what can you see? Is what you see visible in which image? 

c. Based on the result, what is the advantage of fluorescence microscopy over 

transmission microscopy? Explain with the concept of signal-to-noise ratio (SNR). 

3) Diffraction limit of light: In the images of the fluorescent beads, what is the measured size of 

the beads? What is the actual size of them? If they are different, why? Take a few beads in the 

image and measure their Full-width-half-maximum (FWHM) of Gaussian fit. Also, measure the 

thickness of microtubule filaments in the fluorescence image of the cell in the same way. How 

think is it? Is the value the same as known thickness of the microtubule?  

4) From question 4, how are the results related to the optical resolution of the system? How do 

you define a resolution of the system? How is it related to the diffraction limit of light?  

5) Single molecule localization microscopy: In the highlighted area in the regular resolution image 

(“regular.tif”) how many microtubule filaments can you see? 



 
6) In the reconstructed image of SMLM sequence, how many filaments can you see in the same 

area? If you have multiple filaments, what is the separation between them? 

7) What is the thickness of microtubule filaments in the images? Compare the thickness measured 

in the regular image and the SMLM image. If they are different, why? 

8) How can SMLM image the structure smaller than the diffraction limit of light, how can it resolve 

multiple filaments that locate closer than the diffraction limit of light? How can it break the 

diffraction limit? 
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